Задать вопрос
10 ноября, 02:42

Вывести на экран строку, сумма элементов которой максимальна. Формат вывода: Строка 2: 3 5 8 9 8 все это в паскале

+1
Ответы (1)
  1. 10 ноября, 04:08
    0
    var

    i, j, s, n, max:integer;

    a:array[1 ... 5,1 ... 5]of integer;

    begin

    for i:=1 to 5 do

    begin

    s:=0;

    for j:=1 to 5 do

    begin

    a[i, j]:=random (10) ;

    write (a[i, j],' ') ;

    s:=s+a[i, j];

    end;

    if s>max then

    begin

    n:=i;

    max:=s;

    end;

    writeln;

    end;

    writeln;

    write ('Строка ', n,': ') ;

    for j:=1 to 5 do

    write (a[n, j],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вывести на экран строку, сумма элементов которой максимальна. Формат вывода: Строка 2: 3 5 8 9 8 все это в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)
Заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [-10,10] и вывести ее на экран. Вывести на экран строку, произведение элементов которой максимально. Формат вывода: Строка 2: 3 5 8 9 8
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes и сумму элементов строки N1. Если НЕТ - вывести No и сумму элементов строки N2.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)