Задать вопрос
5 октября, 10:38

Вычислить площадь прямоугольного треугольники по формуле Геросса, если заданы его стороны.

+2
Ответы (1)
  1. 5 октября, 11:38
    0
    Var

    a: array [1 ... 4] of real;

    begin

    readln (a[1], a[2], a[3]) ;

    a[4] : = (a[1] + a[2] + a[3]) / 2;

    writeln (sqrt (a[4] * (a[4] - a[1]) * (a[4] - a[2]) * (a[4] - a[3]))) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить площадь прямоугольного треугольники по формуле Геросса, если заданы его стороны. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заданы двоичные числа X и Y. Вычислить X+Y и X-Y, если: а) Х = 1101001, Y = 101111; б) Х = 101110110, Y = 10111001 в) Х = 100011001, Y = 101011 Заданы двоичные числа X и Y.
Ответы (1)
Помогите составить алгоритм: Требуется рассчитать необходимое кол-во рулонов обоев для оклейки комнаты. Заданы параметры комнаты а, b, h. Заданы параметры рулонов обоев длина l, ширина-d, считаем что S окон и дверей составляет 15 % от площади стен.
Ответы (1)
1). Дана площадь S квадрата. Вычислить длину стороны a и длину диагонали d. 2). В прямоугольном треугольнике заданы два катета a и b. Найти гипотенузу С и площадь S.
Ответы (1)
Вычислить периметр и площадь прямоугольника, если заданы его стороны. Нужно написать программу для этой задачи (Pascal)
Ответы (1)
Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).
Ответы (1)