Задать вопрос
5 августа, 00:52

1. Напишите класс, который принимает с клавиатуры двузначное число и проверяет, что больше: само это число или произведение его цифр.

+3
Ответы (1)
  1. 5 августа, 01:52
    0
    Uses crt;

    var a:integer;

    begin

    clrscr;

    if a> ((a mod 10) * (a div 10)) then writeln ('A bolshe') else

    if a< ((a mod 10) * (a div 10)) then writeln ('Proizvedeniye bolshe') else

    writeln ('Ravni') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Напишите класс, который принимает с клавиатуры двузначное число и проверяет, что больше: само это число или произведение его цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1. С клавиатуры вводится число от 100 до 9999. Если число трехзначное, то найти произведение его цифр. Если четырехзначное, то найти сумму этих цифр. 2. Определить, состоит, ли двузначное число, введенное с клавиатуры из одинаковых цифр.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)