Задать вопрос
3 марта, 23:12

Дан одномерный массив целых чисел размерностью 20.

Определите количество положительных групп в этом массиве.

(группа это последовательность состоящая из 2-х и более положительных чисел находящихся рядом.)

+1
Ответы (1)
  1. 4 марта, 00:47
    0
    Const N=20;

    Var m:array[1 ... N]of real;

    i, group:byte;

    fl: boolean;

    Begin

    for i : = 1 to 20 do

    begin

    m[i] : = random (20) - 10;

    writeln ('[', i, '] = > ', m[i]) ;

    end;

    group:=0;

    fl:=false;

    for i:=1 to N-1 do

    If (m[i]>0) and (m[i+1]>0) Then

    fl:=true

    else

    if fl and (m[i+1]<=0) then

    begin

    inc (group) ;

    fl:=false

    end;

    if (fl) then inc (group) ;

    writeln (group) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив целых чисел размерностью 20. Определите количество положительных групп в этом массиве. (группа это последовательность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)