Задать вопрос
14 февраля, 02:29

В массиве записаны оценки по информатике 22 учеников класса. Определить кол-во учеников, оценка которых меньше средней оценки по классу, и вывести номера элементов массива, соответствующих этим ученика.

+3
Ответы (1)
  1. 14 февраля, 05:33
    0
    Program z;

    var i, sum:integer;

    sr:real;

    a:array[1 ... 22] of integer;

    begin

    for i:=1 to 22 do

    begin

    a[i]:=random (9) + 1;

    sr:=sr+a[i];

    end;

    sr:=sr/22;

    for i:=1 to 22 do

    begin

    if (a[i]
    sum:=sum+1;

    writeln (a[i]) ;

    end;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве записаны оценки по информатике 22 учеников класса. Определить кол-во учеников, оценка которых меньше средней оценки по классу, и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Организовать ввод чисел в массив E состоящий из 7 элементов ввод с клавиатуры сформировать новый массив К состоящий из элементов которые равны квадратам элементов массива Е вывести элементы массива Е найти и вывести номер минимального элемента
Ответы (1)