Задать вопрос
9 января, 16:47

Распечатать анкетные данные студентов, получивших в

первую сессию все оценки 5. в паскале

+5
Ответы (1)
  1. 9 января, 20:39
    0
    Var a, b, c, d, i:longint;

    s:string;

    m:array[1 ... 100000] of string;

    begin

    readln (a) ;

    for i:=1 to a do

    begin

    readln (s) ;

    if s[length (s) ]='5' then

    begin

    s[length (s) ]:=' ';

    m[i]:=s;

    end;

    end;

    for i:=1 to a do

    begin

    if m[i]'' then

    writeln (m[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Распечатать анкетные данные студентов, получивших в первую сессию все оценки 5. в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В группе 15 студентов не сдали сессию. Сообщение "Иванов-сдал сессию" несет 1 бит информации. Сколько студентов в группе?
Ответы (1)
полностью заполненного картриджа лазерного принтера хватает, чтобы распечатать 1600 страниц при трехпроцентном заполнении страницы. После включения режима экономии тонера можно распечатать на 20% страниц больше.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Получить двумерный массив случайных чисел в интервале от - 10 до 10. Распечатать размером 5 х5, заменить все четные строчки значением 100. Распечатать измененный массив.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)