Задать вопрос
15 января, 09:27

Дана исходная строка: "12". Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на четных позициях считая слева направо, прибавили по 1. Получилась строка: "1322". Указанный алгоритм обработки применили к этой получившейся строке, затем к строке, которая получилась в результате новой обработки и т. д. Например, после трех применений алгоритма обработки получились следующие строки:

12

1322

14232332

1524243324333342

Посчитай количество нечетных цифр в строке, получившейся после шестого применения алгоритма обработки. В ответе укажите целое число.

+5
Ответы (1)
  1. 15 января, 12:39
    0
    Program test;

    var i, n, k, s1, es, al:integer;

    s:string;

    begin

    write ('Введите кол-во повторений:') ;

    readln (n) ;

    write ('Введите строку:') ;

    readln (s) ;

    repeat

    inc (k) ;

    for i:=length (s) downto 1 do s:=s+s[i];

    for i:=1 to length (s) do

    if i mod 2 = 0 then

    begin

    es:=strtoInt (s[i]) + 1;

    delete (s, i, 1) ;

    insert (InttoStr (es), s, i) ;

    end;

    writeln (k,') ', s) ;

    until k=n;

    for i:=1 to length (s) do

    if StrtoInt (s[i]) mod 2 = 1 then inc (al) ;

    writeln ('Кол-во нечетных чисел: ', al) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана исходная строка: "12". Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность "12". К ней применяют следующий алгоритм: в конец строки дописывают ее зеркальную копию, а затем к цифрам, стоящим на четных позициях, считая слева направо, прибавили по 1. Получилась строка "1322".
Ответы (1)
Дана последовательность, состоящая из двух цифр? 12. К этой последовательности Незнайка решил применить такой алгоритм: 1) в конце данной последовательности дописать ее зеркальную копию;
Ответы (1)
Дана строка-предложение. Зашифровать ее, поместив вначале все символы, расположенные на четных позициях строки, а затем, в обратном порядке, все символы, расположенные на нечетных позициях.
Ответы (1)
Маша получила алгоритм для нахождения кода от числового замка в последовательности цифр каждой цифры стоящие на нечетных позициях прибавить один из каждой цифры стоящие на четных позициях через 20 секунд каждые 3 цифры какой год получает девочка
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)