Задать вопрос
12 июня, 16:29

Pascal

Вычислите среднее арифметическое делителей заданного числа Х

+1
Ответы (1)
  1. 12 июня, 18:26
    0
    Program gt;

    var s:real;

    i, h, x:integer;

    begin

    read (x) ;

    h:=0;

    s:=0;

    for i:=1 to x do

    if (x mod i=0) then begin

    h:=h+1;

    s:=s+i;

    end;

    s:=s/h;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal Вычислите среднее арифметическое делителей заданного числа Х ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
Найти среднее арифметическое значение элементов заданного массива размером 15. Преобразовать исходный массив, вычитая из каждого элемента найденное среднее значение Turbo pascal
Ответы (1)
Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10.
Ответы (1)