Задать вопрос
5 июня, 19:49

Написать программу, определяющую номер квартала по введеному номеру месяца, используя оператор case.

+4
Ответы (1)
  1. 5 июня, 23:26
    0
    Var a, i, k:integer;

    begin

    Writeln ('Введи номер месяца') ;

    Readln (k) ;

    if (k>0) and (k<13) then

    case k of

    1 ... 3: writeln ('Первый квартал') ;

    4 ... 6: writeln ('второй квартал') ;

    7 ... 9: writeln ('третий квартал') ;

    10 ... 12: writeln ('четвертый квартал') ;

    End

    else writeln ('неверный ввод') ;

    Readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, определяющую номер квартала по введеному номеру месяца, используя оператор case. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программы: 1. Запросить у пользователя 2 числа, наибольшее вывести на экран, наименьшее возвести в квадрат и тоже вывести на экран. 2. С помощью структуры case of определить номер квартала по введеному номера месяца.
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два поля: year - для хранения года и month - для месяца. Пользователь вводит год и месяц.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)