Задать вопрос
6 июля, 10:39

Как в паскале запросить у пользователя: день, месяц и год в трех разных переменных. Выдать следующую по календарю дату?

+2
Ответы (1)
  1. 6 июля, 14:13
    0
    Високосные года уже не учитывал (найдёте ошибку - не поленитесь написать в комменты)

    var a, b, c:integer;

    begin

    writeln ('Введите сегодняшний день, месяц, год (например, 1 12 2013) ') ;

    read (a, b, c) ;

    if (((b=1) or (b=3) or (b=5) or (b=7) or (b=8) or (b=10) or (b=12)) and ((a>=1) and (a=1) and (a=1) and (a<=30))) then

    begin

    writeln ('Сегодня ', a,'.', b,'.', c) ;

    if (((b=1) or (b=3) or (b=5) or (b=7) or (b=8) or (b=10) or (b=12)) and ((a>=1) and (a<=31))) and ((a=31) and (b=12)) then writeln ('Завтра 1.1.', c+1) else

    if (((b=1) or (b=3) or (b=5) or (b=7) or (b=8) or (b=10) or (b=12)) and ((a>=1) and (a<=31))) and ((a=31) and (b12)) then writeln ('Завтра 1.', b+1,'.', c) else

    if (((b=1) or (b=3) or (b=5) or (b=7) or (b=8) or (b=10) or (b=12)) and ((a>=1) and (a<=31))) and ((a31) and (b=12)) then writeln ('Завтра ', a+1,'.', b,'.', c) else

    if ((b=2) and ((a>=1) and (a<=28))) and ((a=28) and (b=12)) then writeln ('Завтра 1.1.', c+1) else

    if ((b=2) and ((a>=1) and (a<=28))) and ((a=28) and (b12)) then writeln ('Завтра 1.', b+1,'.', c) else

    if ((b=2) and ((a>=1) and (a<=28))) and ((a28) and (b=12)) then writeln ('Завтра ', a+1,'.', b,'.', c) else

    if (((b=4) or (b=6) or (b=9) or (b=11))) and ((a>=1) and (a<=30)) and ((a=30) and (b=12)) then writeln ('Завтра 1.1.', c+1) else

    if (((b=4) or (b=6) or (b=9) or (b=11))) and ((a>=1) and (a<=30)) and ((a=30) and (b12)) then writeln ('Завтра 1.', b+1,'.', c) else

    if (((b=4) or (b=6) or (b=9) or (b=11))) and ((a>=1) and (a<=30)) and ((a30) and (b=12)) then writeln ('Завтра ', a+1,'.', b,'.', c) else

    writeln ('Завтра ', a+1,'.', b,'.', c) ;

    end else

    writeln ('Неправильная дата') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как в паскале запросить у пользователя: день, месяц и год в трех разных переменных. Выдать следующую по календарю дату? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика Задача Пользователь вводит день (1-30), месяц (1-12), год. Каждый месяц=30 дням Ответ: день: месяц; год Вопрос пользователя: Как получить ответ, например 12:12:2016 выходит ответ вот такой 12122016 Решение Var a, b, c, d:Integer;
Ответы (1)
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)
Задания. 1. Найти простейшую формулу от трёх переменных, принимающую значение 0 только на следующих наборах значений переменных: 7) А (0,0,0) = А (0,1,1) = А (1,0,1) = А (1,1,1) 2.
Ответы (1)
Напишите программу в Паскале) написать программу которая вычисляет дату следующего дня. Введите цифрами сегодняшнюю дату (число, месяц, год) 31 12 1998
Ответы (2)
Что осуществляется с помощью этих трех действий: a=a+b b=a-b a=a-b a) нахождение суммы и разности двух переменных б) нахождение среднеарифметического двух переменных в) обмен значениями двух переменных г) нахождение максимального значения двух
Ответы (1)