Задать вопрос
30 мая, 08:15

Определите, является ли число N простым. (паскаль)

+2
Ответы (1)
  1. 30 мая, 09:15
    0
    Var

    N, l, k: integer;

    begin

    read (N) ;

    if N > 0 then

    k : = 0;

    for l : = 1 to N do

    if N mod l = 0 then k : = k + 1;

    if (k > = 1) and (k < = 2) then writeln ('Простое') else writeln ('Не простое') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите, является ли число N простым. (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задание 1. составьте программу, определяющую, является ли число х простым. число х введите с клавиатуры. число называется простым, если у него нет других делителей, кроме 1 и его самого.
Ответы (1)
Условие: Дано натуральное число. Проверить, является ли оно простым. Примечание: простым называется натуральное число, которое имеет ровно два различных натуральных делителя: единицу и само это число.
Ответы (2)
На каком языке программирования можно писать на егэ? и во всех ли заданиях на этом (этих) языка я слышал что можно бейсик паскаль си питон Но в школе проходят не паскаль а Паскаль АБС можно ли по этому правилу сдавать егэ на С + + или С#?
Ответы (1)