Задать вопрос
22 мая, 10:50

помогите написать программу

Дан фрагмент:

for n:=l to 6 do

for m:=l to 5 do begin

C[n, m]:=C[n, m] + (2*n-m) ;

end;

Чему будет равно значение С[4,3], если перед этими командами значение С[4,3]=10?

Чему будет равно значение С[4,3], если перед этими командами значение С[4,3]=10?

+4
Ответы (1)
  1. 22 мая, 13:52
    0
    Во первых ошибка во фрагменте там должны быть цыфирки 1, а не буква l

    т. е for n:=1 to 6 do

    for m:=1 to 5 do begin

    Текст программы

    Uses crt;

    var c:array[1 ... 6,1 ... 5] of integer;

    n, m:integer;

    begin

    с[4,3]:=10;

    for n:=1 to 6 do

    for m:=1 to 5 do begin

    с[n, m]:=с[n, m] + (2*n-m) ;

    if (m=5) then

    writeln (c[n, m])

    else write (c[n, m],' ') ;

    end;

    writeln; writeln;

    write ('C[4,3]=', C[4,3]) ;

    readkey;

    end.

    Прогоночный вывод

    1 0 - 1 - 2 - 3

    3 2 1 0 - 1

    5 4 3 2 1

    7 6 15 4 3

    9 8 7 6 5

    11 10 9 8 7

    Отсюда получаем что если с[4,3]:=10 перед началом цикла то с[4,3]=15

    в противном случае с[4,3]=5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «помогите написать программу Дан фрагмент: for n:=l to 6 do for m:=l to 5 do begin C[n, m]:=C[n, m] + (2*n-m) ; end; Чему будет равно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы