Задать вопрос
7 декабря, 11:04

В массиве из 10 целых чисел подсчитать сумму

элементов, стоящих правее минимального. на паскале

+1
Ответы (1)
  1. 7 декабря, 13:03
    0
    Uses crt;

    const n=10;

    var a:array[1 ... n] of integer;

    s, i, min, k:integer;

    begin

    min:=1000;

    for i:=1 to n do

    begin

    readln (a[i]) ;

    if a[i]
    end;

    s:=0;

    for i:=k+1 to n do

    s:=s+a[i];

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве из 10 целых чисел подсчитать сумму элементов, стоящих правее минимального. на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Паскаль, помогите! В числовом массиве из 10 элементов, заданных случайным образом от - 100 до 500. Найти: 1) сумму положительных элементов, стоящих на чётных местах; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах;
Ответы (1)