Задать вопрос
13 сентября, 16:37

По данным x, y составить программу в Паскале для вычисления функции z:

1) z = (min (x, y) + 0,5)) / (1+max^2 (x, y)).

2) z=система max (x, y), x<0

min (x, y), x>=0.

+5
Ответы (1)
  1. 13 сентября, 18:17
    0
    1) var x, y, z, min, max:real;

    begin

    readln (x, y) ;

    if x>y then

    begin

    max:=x;

    min:=y;

    end

    else if x
    begin

    max:=y;

    min:=x;

    end;

    z: = (min+0.5) / (1+sqr (max)) ;

    writeln (z) ;

    end.

    2) var x, y, z, min, max:real;

    begin

    readln (x, y) ;

    if x>y then

    begin

    max:=x;

    min:=y;

    end

    else if x
    begin

    max:=y;

    min:=x;

    end;

    if x<0 then

    z:=max

    else if x>=0 then

    z:=min;

    writeln (z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «По данным x, y составить программу в Паскале для вычисления функции z: 1) z = (min (x, y) + 0,5)) / (1+max^2 (x, y)). 2) z=система max (x, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы