Задать вопрос
29 октября, 16:21

Дано 3-х значное число (х). Составить программу для вычесления суммы и произведения цифр числа

Program ynp2;

var x, x1, x2, x3; p: integer;

begin

Write (' введите трёхзначное число') ;

Read (x) ;

x1: x mod 100;

x3: x div 100;

+5
Ответы (1)
  1. 29 октября, 19:42
    0
    Var number, a, b, c:integer;

    begin

    writeln ('Введите трёхзначное число') ;

    readln (number) ;

    a:=number div 100;

    b: = (number div 10) mod 10;

    c:=number mod 10;

    writeln (a,' - Первая цифра числа') ;

    writeln (b,' - Вторая цифра числа') ;

    writeln (c,' - Третья цифра числа') ;

    writeln ('Сумма цифр числа = ', a+b+c) ;

    writeln ('Произведение цифр числа = ', a*b*c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 3-х значное число (х). Составить программу для вычесления суммы и произведения цифр числа Program ynp2; var x, x1, x2, x3; p: integer; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике