Задать вопрос
18 апреля, 17:12

Помогите составить программу, вычисляющую сумму квадратов n чётных натуральных чисел

(сейчас прошли циклические алгоритмы, нужна и блок-схема)

+3
Ответы (1)
  1. 18 апреля, 21:00
    0
    Var n, a, i:integer;

    s:longint;

    begin

    writeln ('введите количество чисел') ;

    readln (n) ;

    a:=0; s:=0;

    writeln ('введите числа') ;

    for i:=1 to n do begin

    readln (a) ;

    if a>10 then s:=s+a*a;

    end;

    if s=0 then writeln ('положительных чисел нет') else writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу, вычисляющую сумму квадратов n чётных натуральных чисел (сейчас прошли циклические алгоритмы, нужна и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
какие из предложенных высказываний являются ложными? 1) человек разрабатывает алгоритмы 2) компьютер разрабатывает алгоритмы 3) исполнитель разрабатывает алгоритмы 4) исполнитель четко и безошибочно выполняет алгоритмы, составленные из команд,
Ответы (2)
Что из этого являются истинными высказываниями? 1. человек исполняет алгоритмы 2. компьютер сам выполняет алгоритмы (программы) 3. исполнитель четко и безошибочно выполняет алгоритмы, составленные из команд, входящих в его СКИ. 4.
Ответы (1)
Выберите истинные высказвания. а) Человек разрабатывает алгоритмы б) Компьютер разрабатывает алгоритмы в) Исполнитель разрабатывает алгоритмы г) Человек управляет работой других исполнителей по выполнению алгоритмов д) Компьютер управляет работой
Ответы (2)
Укажите истинные высказывания: 1. а) Человек разрабатывает алгоритмы б) Человек управляет работой других исполнителей по выполнению алгоритмов в) Человек исполняет алгоритмы 2.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)