Задать вопрос
17 мая, 17:40

Даны 3 целочисленных числа если среди этих 3-х чисел есть равные вывести сообщение об ошибке. иначе найти среднее и его вывести

Язык C (си)

+5
Ответы (1)
  1. 17 мая, 20:08
    0
    Если возникает ошибка "undefined reference to", компилируйте с флагом - lm

    #include

    #include

    int main ()

    {

    int val[3];

    printf ("Введите 3 числа: ") ;

    scanf ("%d%d%d", &val[0], &val[1], &val[2]) ;

    if (val[0] = = val[1] || val[1] = = val[2] || val[0] = = val[2])

    printf ("[Ошибка] Найдено повторяющееся число!/n") ;

    else

    {

    printf ("Среднее арифметическое = %d/n", (val[0] + val[1] + val[2]) / 3) ;

    printf ("Среднее геометрическое = %.2f/n", cbrt (val[0] * val[1] * val[2])) ;

    }

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 3 целочисленных числа если среди этих 3-х чисел есть равные вывести сообщение об ошибке. иначе найти среднее и его вывести Язык C (си) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Используя условный оператор if написать конструкцию которая проверяет возраст и выводит соответствующие значения по такому словию: Если возраст больше либо равен 18 - вывести сообщение "ok" иначе если возраст больше 14 - вывести сообщение "with
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Дан массив А из N целочисленных элементов. 1) Заполнить массив А целыми числами в интервале[1,100] и вывести на экран. Найти максимальный четный элемент и вывести его на экран.
Ответы (1)