Задать вопрос
20 августа, 15:15

Clrscr; ДАЮ 30 Б

Составить программу на языке Паскаль, возведения числа х в степень числа y.

+1
Ответы (1)
  1. 20 августа, 16:44
    0
    var

    x, y, result:real;

    begin

    readln (x, y) ;

    result : = 1;

    if y > 0 then

    begin

    while y 0 do

    begin

    result : = result * x;

    y : = y - 1;

    end;

    end

    else if y < 0 then

    begin

    while y 0 do

    begin

    result : = result * x;

    y : = y + 1;

    end;

    result : = 1 / result;

    end

    else result : = 1;

    writeln ('x^y = ', result) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Clrscr; ДАЮ 30 Б Составить программу на языке Паскаль, возведения числа х в степень числа y. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
ДАЮ 30 Б Составить программу на языке Паскаль, возведения числа х в степень числа y.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Помогите составить программу на языке Паскаль! Дано натуральное число N. Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае. Операцией возведения в степень пользоваться нельзя!
Ответы (1)