Задать вопрос
9 октября, 22:12

Сделать небольшую программу в паскале

В параде принимают участие M военных. Командование парада решило, что наиболее

эффектное построение военных - в форме квадрата, то есть число участников построения

должно быть точным квадратом. Но поскольку число M может не быть точным квадратом,

разрешается разбить военных на несколько полков, каждый из которых строится в форме

квадрата. Для красоты все полки должны быть одинакового размера, также командование

парада хочет, чтобы размер каждого полка был как можно больше. Определите максимально

возможный размер полка.

Программа получает на вход одно целое положительное число M,

не превосходящее 2*109

, - количество участников парад. Программа должна вывести одно

число - максимально возможный размер полка.

Пример входных и выходных данных

Ввод Вывод

180 36

+5
Ответы (1)
  1. 10 октября, 01:02
    0
    var m, k: integer;

    begin

    readln (m) ;

    k:=round (sqrt (m)) ;

    while m mod sqr (k) 0 do k:=k-1;

    writeln (k*k) ;

    end.

    Пример:

    180

    36
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сделать небольшую программу в паскале В параде принимают участие M военных. Командование парада решило, что наиболее эффектное построение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Решите на пасхале Задача: Найти количество четных цифр натурального числа. Формат ввода: На вход подается натуральное, не превосходящее 30000. Формат вывода: Целое число. Пример входных данных 321 Пример выходных данных 1
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
На вход программы поступает последовательность из N натуральных чисел. Нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4.
Ответы (1)