Задать вопрос
31 октября, 03:34

Решите задачу на одномерный массив.

Определите количество 0 в заданном массиве.

+4
Ответы (1)
  1. 31 октября, 07:33
    0
    var a:array[1 ... 100000] of integer;

    i, n, k:integer;

    begin

    k:=0;

    readln (n) ;

    for i:=1 to n do begin readln (a[i]) ; if (a[i]=0) then k:=k+1; end;

    writeln (k) ;

    end.

    {Сначала вводится количество чисел в массиве (n), после этого вводится каждое число (a[i]) и если оно равно 0, то переменная k (количество)

    увеличивается на 1}
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите задачу на одномерный массив. Определите количество 0 в заданном массиве. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Что такое одномерный массив в информатике? Для чего используется одномерный массив? Как описывается одномерный массив?
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)