Задать вопрос
28 октября, 05:15

Используя средства языка Паскаль, сформировать массив из 15 чисел по формуле Ai=cos 5i-1/корень из i^3+9. Написать функцию для подсчета кол-ва элементов массива, значения которых меньше среднего арифметического его элементов

+1
Ответы (1)
  1. 28 октября, 05:47
    0
    Const

    n=15;

    type

    tm=array [1 ... n] of real;

    function fk (a:tm) : integer;

    var

    i, k:integer;

    m:real;

    begin

    m:=0;

    for i:=1 to n do

    m:=m+a[i];

    m:=m/n;

    k:=0;

    for i:=1 to n do

    if a[i]
    fk:=k

    end;

    var

    a:tm;

    i:integer;

    begin

    for i:=1 to n do

    begin

    a[i]:=cos (5*i) - 1/sqrt (i*i*i+9) ;

    Write (a[i]:13:9)

    end;

    Writeln;

    Writeln ('Элементов меньше среднего: ', fk (a))

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Используя средства языка Паскаль, сформировать массив из 15 чисел по формуле Ai=cos 5i-1/корень из i^3+9. Написать функцию для подсчета ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Напишите программу с помощью Паскаля. Сформировать массив случайным образом (длина массива 20). Найти в нем среднее арифметическое. Сформировать новый массив из элементов первого больших среднего арифметического.
Ответы (2)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)