Задать вопрос
9 июля, 12:27

С клавиатуры вводится дата в формате

+3
Ответы (1)
  1. 9 июля, 16:25
    0
    var s:string; d1, m1, g1, d2, m2, g2, t, c:integer; p:boolean; k:byte; begin

    k:=0;

    writeln ('Введите дату в формате дд. мм. гг') ; readln (s) ; val (copy (s, 7,2), t, c) ; {преобразуем год в число}if (c0) or (t<0) then k:=1 else g1:=t; {определим високосный год или нет}if (((g1+2000) mod 1000) and ((g1+2000) mod 4=0)) or ((g1+2000) mod 400=0) then p:=trueelse p:=false;

    val (copy (s, 4,2), t, c) ; if (c0) or not (t in [1 ... 12]) then k:=1 else m1:=t;

    val (copy (s, 1,2), t, c) ; if (c0) or ((m1 in [1,3,5,7,8,10,12]) and not (t in [1 ... 31])) or ((m1 in [4,6,9,11]) and not (t in [1 ... 30])) or (p and (m1=2) and not (t in [1 ... 29])) or (not p and (m1=2) and not (t in [1 ... 28])) then k:=1 else d1:=t; if k=1 thenbeginwriteln ('Дата введена неверно!') ; endelsebeginif (m1=1) and (d1=1) then begin d2:=31; m2:=12; g2:=g1-1; end

    else if ((m1 in [5,7,10,12]) and (d1=1)) then begin d2:=30; m2:=m1-1; g2:=g1; end

    else if ((m1 in [2,4,6,8,9,11]) and (d1=1)) then begin d2:=31; m2:=m1-1; g2:=g1; end

    else if (m1=3) and (d1=1) then begin if p then d2:=29 else d2:=28; m2:=m1-1; g2:=g1; end

    else begin d2:=d1-1; m2:=m1; g2:=g1; end; writeln ('Предыдущая дата:') ; if d2<10 then write ('0', d2,'.') else write (d2,'.') ; if m2<10 then write ('0', m2,'.') else write (m2,'.') ; write (g2) ; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится дата в формате ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
1) Представьте двоичное число 11011,11 в четырехбайтовом формате. Представьте число сначала в формате с плавающей запятой. 2) Представьте число 1110,101 в четырехбайтовом формате. Представьте число сначала в формате с плавающей запятой.
Ответы (1)
Представить положительное и отрицательное числа + 372 и - 372 в форматах В формате слово (2 байта) со знаком и фиксированной запятой. В формате двойное слово (4 байта) с плавающей запятой. В упакованном формате. В распакованном формате.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)