Задать вопрос
12 декабря, 04:51

Отделить первую и вторую цифру трехзначного числа, найти сумму всех цифр, перевернуть число

+1
Ответы (1)
  1. 12 декабря, 06:21
    0
    В моем коде выводится все в три строчки. На первой 1 и2 цифры. На второй их сумма. На третей перевернутое число:

    var a, a1, a2, a3, s:integer;

    begin

    Read (a) ;

    a1: = a div 100;

    a2: = a div 10;

    a2: = a2 mod 10;

    a3: = a mod 100;

    s: = a1 + a2 + a3;

    a: = a3 * 100 + a2*1 + a1;

    Writeln (a1, a2) ;

    Writeln (s) ;

    Writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Отделить первую и вторую цифру трехзначного числа, найти сумму всех цифр, перевернуть число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Дано трехзначное целое число Х. Найти остаток от деления произведения всех его цифр на сумму всех его цифр. Вывести новое число Y, поменяв местами вторую и третью цифру числа X.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)