Задать вопрос
23 октября, 19:26

Решите в Pascal: известно расстояние до каждого из трёх сёл от районного центра. Определить, какое из них находится ближе всего к районному центру, а какое дальше всего от него

+3
Ответы (1)
  1. 23 октября, 23:24
    0
    Если условие задачи перевести на математику, то имеем три числа (три расстояния), среди которых нужно найти самое маленькое (минимум), и самое большое (максимум). Другими словами, найти минимальное и максимальное из трех заданных чисел.

    program z;

    var min, max, x:real;

    i:integer;

    begin

    readln (x) ; {ввод первого числа}

    min:=x; {принять первое число за минимум на начало счета}

    max:=x; {принять первое число за максимум на начало счета}

    for i:=2 to 3 do {считать остальные два числа}

    begin

    readln (x) ; {ввести очередное число}

    if x>max then max:=x; {если введенное число больше текущего максимума, считать его максимумом}

    if x
    end;

    writeln ('min=', min) ; {вывод минимума}

    writeln ('max=', max) ; {вывод максимума}

    end.

    Замечание. Программа не использует массив, т. к. чисел всего три. В более общем случае лучше ввести числа в массив и выполнить его сортировку.

    Вариант без цикла и с отдельными переменными для каждого числа

    program z1;

    var min, max, x, y, z:real;

    begin

    readln (x) ; {ввод первого числа}

    min:=x; {принять первое число за минимум на начало счета}

    max:=x; {принять первое число за максимум на начало счета}

    readln (y) ; {ввести второе число}

    if y>max then max:=y; {если введенное число больше текущего максимума, считать его максимумом}

    if y
    readln (z) ; {ввести третье число}

    if z>max then max:=z; {если введенное число больше текущего максимума, считать его максимумом}

    if z
    writeln ('min=', min) ; {вывод минимума}

    writeln ('max=', max) ; {вывод максимума}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите в Pascal: известно расстояние до каждого из трёх сёл от районного центра. Определить, какое из них находится ближе всего к районному ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Объясните. Я нахожусь в дома, дом находится на улице, улица находится в городе, город находится в стране, страна находится на континенте, континент находится в космосе, космос находится во Вселенной. А где находится Вселенная?
Ответы (2)