Задать вопрос
18 августа, 16:08

Нужно запрограммировать в паскале задачку. С блок-схемой и пояснениями, если можно

С клавиатуры вводится целое число N<100. Вывести на экран все его делители. Если число простое (делится только на себя и на 1), вывести сообщение.

+1
Ответы (1)
  1. 18 августа, 18:02
    0
    Var n, i, k:Integer;

    begin

    write ('Введите целое число (n<100) : ') ;

    readln (n) ;

    for i:=1 to n do

    if n mod i = 0 then

    begin

    writeln ('Делитель числа ', n,': ', i:2) ;

    k:=k+1

    end;

    if k=2 then writeln ('Число ', n,' простое')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно запрограммировать в паскале задачку. С блок-схемой и пояснениями, если можно С клавиатуры вводится целое число N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)