Задать вопрос
16 мая, 02:06

Программисты, помогите! нужно написать программу на паскале. дано натуральное число n. Возвести в степень n число 2. С Longint и integer.

+2
Ответы (2)
  1. 16 мая, 04:46
    0
    Var

    n, i: longint;

    a: int64;

    begin

    readln (n) ;

    a : = 2;

    for i : = 2 to n do

    a : = a * 2;

    writeln (a) ;

    end.
  2. 16 мая, 04:47
    0
    Program z1;

    var a, n:longint;

    c:real;

    begin

    writeln ('Введите N=') ;

    read (n) ;

    a:=2;

    c:=power (a, n) ;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программисты, помогите! нужно написать программу на паскале. дано натуральное число n. Возвести в степень n число 2. С Longint и integer. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы