Задать вопрос
29 августа, 06:07

Программисты, помогите! нужно написать программу на паскале дано натуральное число n. Найти произведение нечетных чисел от 1 до n. C Longint и integer.

+4
Ответы (1)
  1. 29 августа, 08:39
    0
    Var

    n, i: integer;

    pr: longint;

    begin

    readln (n) ;

    pr : = 1;

    i : = 1;

    while (i < = n) do begin

    i : = i + 2;

    pr : = pr * i;

    end;

    pr : = pr div i;

    writeln (pr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программисты, помогите! нужно написать программу на паскале дано натуральное число n. Найти произведение нечетных чисел от 1 до n. C ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы