Задать вопрос
7 ноября, 14:44

Дано 20 чисел. Найти сумму чисел, которые меньше числа 5.

(Паскаль)

+5
Ответы (1)
  1. 7 ноября, 14:57
    0
    Program pr1;

    uses crt;

    var

    n:byte; / / Размерность массива

    i:byte; / / Счетчик массива

    a:array[1 ... 20] of real; / / Массива чисел

    S:real; / / Сумма чисел

    Begin

    clrscr;

    write ('Введите размерность массива: ') ;

    readln (n) ;

    writeln ('Введите ', n,' элементов') ;

    / / Блок ввода

    for i:=1 to n do

    readln (a[i]) ;

    / / Блок вывода

    writeln ('Исходный массив') ;

    for i:=1 to n do

    write (a[i]:6:1,' ') ;

    writeln;

    readln;

    / / Блок инициализации

    S:=0;

    for i:=1 to n do

    if (a[i]<5) then

    S:=S+a[i];

    readln;

    writeln ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 20 чисел. Найти сумму чисел, которые меньше числа 5. (Паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1) найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2) вывести на экран натуральные нечетные числа от 5 до 55. тоже паскаль 3) найти произведение последовательных натуральных чисел от n до m.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)