Задать вопрос
20 июня, 03:12

Сумма всех чётных чисел от 1 до N с клавиатуры

Паскаль

+2
Ответы (1)
  1. 20 июня, 07:04
    0
    program summa;

    var i, a, n, sum:integer;

    begin

    writeln ('Введите n') ;

    read (n) ;

    sum:=0;

    for i:=1 to n do

    begin

    read (a) ;

    if (a mod 2=0) then sum:=sum+a;

    end;

    writeln ('Cумма всех четных чисел = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сумма всех чётных чисел от 1 до N с клавиатуры Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Написать программу на языке паскаль. С клавиатуры вводятся несколько натуральных целых чисел. Необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел.
Ответы (1)
Паскаль 5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 (значение a вводится с клавиатуры; b>=10) в) третьи степени всех целых чисел от a до 50 (значение a вводится с клавиатуры; a
Ответы (1)