Задать вопрос
2 декабря, 23:49

Написать программу, которая с клавиатуры запрашивает размер двумерного массива найти и вывести на экран сумму значений элементов расположенных в левом верхнем углу матрицы и правом нижним? Pascal

+2
Ответы (1)
  1. 3 декабря, 00:17
    0
    Осталось понять что подразумевалось под словом угол.

    Ну допустим что угол это одна самая угловая ячейка

    var

    a: array [1 ... 20,1 ... 20] of Integer;

    i, j, n, sum:Integer;

    begin

    Writeln ('Введмте размер двумерного массива (2<=n<=20) ') ;

    ReadLn (n) ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=Random (20) ;

    Write (a[i, j]:3) ;

    end;

    WriteLn () ;

    end;

    sum:=a[1,1]+a[n, n];

    WriteLn ('Сумма значений элементов расположенных в левом верхнем и в правом нижнем углах = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая с клавиатуры запрашивает размер двумерного массива найти и вывести на экран сумму значений элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)