Задать вопрос
16 марта, 18:04

PascalABC. Дана матрица A (M, N). Возвести в квадрат все отрицательные элементы матрицы.

+5
Ответы (1)
  1. 16 марта, 18:13
    0
    type

    tarray = array [1 ... 50,1 ... 50] of longint;

    var

    a : tarray;

    n, m, i, j : longint;

    begin

    readln (n, m) ;

    for i:=1 to n do

    for j:=1 to m do read (a[i, j]) ;

    for i:=1 to n do

    for j:=1 to m do

    if a[i, j]<0 then a[i, j]:=a[i, j]*a[i, j];

    for i:=1 to n do

    begin

    for j:=1 to m do write (a[i, j],' ') ;

    writeln;

    end;

    end.

    Вместо знака? поставь максимальные значения N и M.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «PascalABC. Дана матрица A (M, N). Возвести в квадрат все отрицательные элементы матрицы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В противном случае все отрицательные элементы матрицы возвести в квадрат.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Помогите написать программу на VisualBasic! Дана матрица Y (5,5) (элементы матрицы выбрать самостоятельно). Вы- числить элементы новой матрицы Z (5,5) по правилу: zij = yij / ki, где ki - количе- ство положительных элементов i-той строки.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)