Задать вопрос
24 марта, 08:42

Дано несколько чисел. Напишите программу, вычисляющую их сумму. Сначала вводится количество чисел N, затем вводится ровно N целых чисел. Используйте цикл for.

+1
Ответы (1)
  1. 24 марта, 11:06
    0
    Var

    mas: array[1 ... 99999] of integer;

    n, i, sum: integer;

    begin

    write ('Сколько чисел? ') ;

    readln (n) ;

    writeln ('Введите числа:') ;

    for i : = 1 to n do

    begin

    readln (mas[i]) ;

    sum : = sum + mas[i];

    end;

    writeln ('Сумма = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано несколько чисел. Напишите программу, вычисляющую их сумму. Сначала вводится количество чисел N, затем вводится ровно N целых чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)