Задать вопрос
5 августа, 21:05

Дано 4-х значное число. Сделать так, чтобы количество десятков стало 0.

Задача в Паскале. Нужен алгоритм.

+1
Ответы (1)
  1. 6 августа, 00:39
    0
    var c, b1, b2:integer;

    begin

    readln (c) ; / / Считываем число

    b1:=c mod 10; / / Единицы

    b2: = (c - b1) mod 100; / / Десятки

    write (c-b2) ; / / Вычитаем из числа десятки

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 4-х значное число. Сделать так, чтобы количество десятков стало 0. Задача в Паскале. Нужен алгоритм. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите как решать Ниже на 5 языках программирования записан алгоритм. Получив на вход число х, этот алгоритм печатает число l. Укажите наибольшее нечетное число х, при вводе которого алгоритм печатает 102.
Ответы (1)
Линейка нужна для ... Транспортир нужен для ... Термометр нужен для ... Барометр нужен для ... Компас нужен для ... Телескоп нужен для ... Микроскоп нужен для Напишите определение
Ответы (1)
Л=Линейка нужна для ... транспортир нужен для ... термометр нужен для ... барометор нужен для ... компас нужен для ... телескоп нужен для ... микроскоп нужен для ... часы нужны для ... посуда нужна для ...
Ответы (1)
Запишите ответы, продолжив слдующие фразы. Линейка нужна для Транспортир нужен для Термометр нужен для Барометр нужен для Компас нужен для Телескоп нужен для Микроскоп нужен для
Ответы (1)