Задать вопрос
4 мая, 16:31

Дана последовательность из N произвольных целых чисел. Написать программу, которая определяет, сколько в этой последовательности отрицательных чисел, кратных 7 (Использовать все три вида цикла For, While, Repeat)

+2
Ответы (1)
  1. 4 мая, 19:23
    0
    Program SomeProgram; var a : array[0 ... 3] of Integer = (1,7,-7,-14) ; i : integer; count : integer = 0; begin

    / / с помощью for in, возможно вам нужно с помощью обычного for for i in a do begin if ((i div 7) < 0) then begin count : = count + 1; end; end; writeln (' (for) количество подходящих чисел: ', count) ; / / с помощью while i : = 0; count : = 0; while (i < length (a)) do begin if ((a[i] div 7) < 0) then begin count : = count + 1; end; i : = i + 1; end; writeln (' (while) количество подходящих чисел: ', count) ; / / с помощью repeat until / / тут главное правльно поставить условие после until i : = 0; count : = 0; repeat if ((a[i] div 7) < 0) then begin count : = count + 1; end; i : = i + 1; until i = length (a) ; writeln (' (repeat until) количество подходящих чисел: ', count) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность из N произвольных целых чисел. Написать программу, которая определяет, сколько в этой последовательности ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)