Задать вопрос
17 ноября, 13:40

Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень

+4
Ответы (1)
  1. 17 ноября, 17:00
    0
    Программа, которая сравнивает первые 3 со вторыми 3 мя ниже, но я не понял к чему было упоминание корня в первоначальном задании

    Program bilet;

    var

    a, b, c:longint;

    i:byte;

    begin

    writeln ('vvrdite nomer') ;

    readln (a) ;

    b:=0;

    c:=0;

    for i:=1 to 6 do

    if i<4 then begin

    b:=b + (a mod 10) ;

    a:=a div 10;

    end

    else begin

    c:=c + (a mod 10) ;

    a:=a div 10;

    end;

    if b=c then writeln ('schastlivuy ', c,' = ', b)

    else writeln ('uvyu ', c,' ', b) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу паскаль для нахождениявсех счастливых автобусных билетов чтобы из низ извлекался квадратный корень
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)