Задать вопрос
12 августа, 20:52

Написать программы в Паскале ABC

1. Дан массив из N действительных чисел. Определить, является ли этот массив возрастающей последовательностью.

2. (Составить схему алгоритма и программу обработки двумерных массивов)

Матрицу A (n*m) преобразовать в матрицу B, вычеркнув строку и столбец, на пересечении которых расположен минимальный элемент матрицы A.

+5
Ответы (1)
  1. 12 августа, 22:21
    0
    Const N = 10;

    begin

    var a: array[1 ... N] of real;

    var i: integer;

    var growing: boolean;

    for i : = 1 to N do begin

    readln (a[i]) ;

    end;

    growing : = true;

    for i : = 2 to N do begin

    if a[i] < = a[i - 1] then begin

    growing : = false;

    break;

    end;

    end;

    writeln (growing) ;

    end.

    const m = 5;

    const n = 4;

    const limit = 100;

    begin

    var matrix: array[1 ... m] of array[1 ... n] of real;

    var matrixb: array[1 ... m - 1] of array[1 ... n - 1] of real;

    var row, col, rb, cb, lowest_row, lowest_col: integer;

    var lowest: real;

    var p: boolean;

    lowest : = limit;

    for row : = 1 to m do begin

    for col : = 1 to n do begin

    matrix[row][col] : = random (limit - 1) ;

    if matrix[row][col] < lowest then begin

    lowest : = matrix[row][col];

    lowest_col : = col;

    lowest_row : = row;

    end;

    write (matrix[row][col], ' ') ;

    end;

    writeln ('') ;

    end;

    writeln ('') ;

    writeln (lowest) ;

    writeln ('') ;

    rb : = 1;

    for row : = 1 to m do begin

    p : = false;

    cb : = 1;

    for col : = 1 to n do begin

    if (not (col = lowest_col)) and (not (row = lowest_row)) then begin

    p : = true;

    matrixb[rb][cb] : = matrix[row][col];

    cb : = cb + 1;

    end;

    end;

    if p then begin

    rb : = rb + 1;

    end;

    end;

    for rb : = 1 to m - 1 do begin

    for cb : = 1 to n - 1 do begin

    write (matrixb[rb][cb], ' ') ;

    end;

    writeln ('') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программы в Паскале ABC 1. Дан массив из N действительных чисел. Определить, является ли этот массив возрастающей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле: Вычислить сумму положительных элементов матрицы А (10 х10), расположенных над главной диагональю.
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)