Задать вопрос
16 июня, 15:33

Составьте программу на Паскале, которая вводит 2 целых числа M и N и печатает все целые числа между M и N, делящиеся на 7, включая и сами эти числа. Замечание: программа должна учитывать, что заранее не известно, какое из чисел M или N больше другого.

+2
Ответы (1)
  1. 16 июня, 15:39
    0
    var i, n, k, f:integer;

    begin

    writeln ('Vvedite n: ') ; readln (n) ;

    for i:=1 to n do

    begin

    k:=i; f:=0;

    while (k0) do

    begin

    if (k mod 10>0) and (i mod (k mod 10) >0) then f:=1;

    k:=k div 10;

    end;

    if (f=0) and (i mod 10>0) then write (i,' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу на Паскале, которая вводит 2 целых числа M и N и печатает все целые числа между M и N, делящиеся на 7, включая и сами ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)
3. Напишите и выполните программу на компьютере a. Программа вводит одно число, и вычисляет его квадрат, вычитая из него удвоенное значение введенного числа. b. Программа вводит два числа, выводит сумму квадратов этих чисел минус их произведение. c.
Ответы (1)