Задать вопрос
8 января, 21:43

Даны три действительный числа а, б, с, определить, можно ли построить треугольник с такими длиннами сторон.

+1
Ответы (1)
  1. 9 января, 01:08
    0
    [Код написан и выполнен на языке C++]

    Алгоритм задачи исходит из неравенства треугольника:

    1) a < b + c, 2) b < a + c, 3) c < a + b

    #include

    using namespace std;

    int main () {

    unsigned int a, b, c;

    cout << "Введите три стороны треугольника (a, b, c) : ";

    cin >> a >> b >> c;

    if ((a < (b + c)) && (b < (a + c)) && (c < (a + b))) {

    cout << endl << "Треугольник со сторонами " << a << ", " << b << " и " << c << " можно построить." << endl;

    return 0;

    }

    else cout << endl << "Треугольник с такими сторонами нельзя построить." << endl;

    system ("pause") ;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны три действительный числа а, б, с, определить, можно ли построить треугольник с такими длиннами сторон. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны три произвольных числа a, b, c, значение которых задают длины сторон треугольника. Выведите 0, если нельзя построить треугольник с такими длинами сторон; 3, если получается равностороний треугольник; 2 равнобедренный; 1 в остальных случаях.
Ответы (1)
Помогите решить (python 3.6) Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)
напишите программу: даны действительные числа a b c. если нельзя построить треугольник с такими сторонами то напечатать 0, иначе 3,2 или 1 в зависимости от того, равносторонний этот треугольник, равнобедренный или какой-либо другой.
Ответы (1)
Информатика: решение задачи на языке Паскаль. Текст задачи: даны три натуральных числа. Напишите программу, определяющую существует ли треугольник с такими длинами сторон.
Ответы (1)
Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)