Задать вопрос
12 октября, 00:44

В массиве, состоящем из 20 случайных чисел в интервале [-10; 10] количество и сумму элементов которые больше 5

+4
Ответы (1)
  1. 12 октября, 03:27
    0
    Var a: array[0 ... 20] of Integer;

    i, sum, count: Integer;

    begin

    sum:=0;

    count:=0;

    for i:=0 to 19 do

    begin

    a[i]:=random (21) - 10;

    writeln ('Число ', i+1,': ', a[i]) ;

    if a[i]>5 then

    begin

    sum:=sum+a[i];

    count:=count+1;

    end;

    end;

    writeln ('Сумма: ', sum) ;

    writeln ('Кол-во: ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве, состоящем из 20 случайных чисел в интервале [-10; 10] количество и сумму элементов которые больше 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. В массиве А (11) случайных целых чисел (диапазон чисел [-10 ... 25]) определить: сумму элементов, которые кратны 5. 2. В массиве B (6) случайных целых чисел (диапазон чисел [-4 ... 53]) определить: количество элементов, которые меньше 7.
Ответы (1)
В массиве состоящем из 10 случайных элементов в интервале [-15; 15], определить: -последний максимум -минимум среди положительных элементов -количество max элементов. Pascal abc, 9 класс
Ответы (1)
В массиве, состоящем из 10 случайных чисел в интервале[-20; 10], определите количество и сумму элементов кратных 3. Pascal ABC. 9 класс
Ответы (2)