Задать вопрос
11 сентября, 14:28

Pascal

Ввести целое число и найти сумму его цифр

Написать цикл со счетчиком

+3
Ответы (1)
  1. 11 сентября, 16:53
    0
    var n, m, i, k, o:integer;

    s:string;

    begin

    readln (n) ; / / программа спрашивает, какое число будем анализировать и присваивает его переменной n

    str (n, s) ; / / получаем строку из числа

    for i:=1 to length (s) do

    begin

    val (s[i], k, o) ; / / посимвольно переводим строку в символ

    m: = k + m; / / и суммируем все в переменную m

    end;

    writeln (m) ; / / выводим сумму цифр

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal Ввести целое число и найти сумму его цифр Написать цикл со счетчиком ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Ввести целое число и найти сумму его цифр. Пример Введите целое число 1234 Сумма цифр числа 1234 равна 10 2. Вычислить в Паскале степень числа, используя цикл while
Ответы (1)