Задать вопрос
29 декабря, 23:00

Создайте и протестируйте программу вычисления расстояния AB между точками с коорднатами (X1, Y1) и (X2, Y2), которые вводятся с клавиатуры паскаль решение

+4
Ответы (2)
  1. 29 декабря, 23:56
    0
    Var x1, x2, y1, y2, s: real;

    begin

    read (x1, y1, x2, y2) ;

    s:=sqrt ((x2-x1) * (x2-x1) + (y2-y1) * (y2-y1)) ;

    write (s:0:3) ;

    end.
  2. 30 декабря, 00:25
    0
    Program Coords;

    var x1, x2, y1, y2, S:real;

    begin

    write ('Введите X1 : ') ; readln (X1) ;

    write ('Введите Y1 : ') ; readln (Y1) ;

    write ('Введите X2 : ') ; readln (X2) ;

    write ('Введите Y2 : ') ; readln (Y2) ;

    S:=sqrt (sqr (x2-x1) + sqr (y2-y1)) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создайте и протестируйте программу вычисления расстояния AB между точками с коорднатами (X1, Y1) и (X2, Y2), которые вводятся с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)