Задать вопрос
8 марта, 18:49

1. Вывести сообщение об отсутствии цифры 1. (Пример. 200 - число не содержит 1, 221 - число содержит 1).

2. Изменить первую и третью цифры в 3-х значном числе.

+4
Ответы (1)
  1. 8 марта, 20:27
    0
    Pascal / Delphi

    1) Program zadanie_1;

    var ss: string; i: integer; flag: boolean;

    begin

    write ('Введите число: ') ;

    readln (ss) ;

    for i:=1 to length (ss) do

    if (ss[i]='1') then begin flag:=true; break; end else flag:=false;

    if (flag=true) then writeln ('Число содержит 1') else writeln ('Число не содержит 1') ;

    readln;

    end.

    2) Program zadanie_2;

    var n, c, c1, c2, c3: integer;

    begin

    write ('Введите число: ') ;

    readln (n) ;

    c1:=n div 100;

    c2:=n mod 100 div 10;

    c3:=n mod 100 mod 10;

    c:=c3*100+c2*10+c1;

    writeln ('Новое число: ', c) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Вывести сообщение об отсутствии цифры 1. (Пример. 200 - число не содержит 1, 221 - число содержит 1). 2. Изменить первую и третью цифры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
А) 5 Кб = ? Байтовб) 6 Мбайт = ? Кбайтв) 1024 бит = ? Кбайт 2. Сколько Мбайт информации содержит сообщение объемом 2 28 бит?. 3. Сколько бит информации содержит сообщение объемом 16 Кб? 4.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
В паскале! В любом трехзначном числе удалить первую цифру, а в оставшемся 2-х значном числе переставить цифры.
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)