Задать вопрос
3 декабря, 14:28

1. С клавиатуры вводитсядет N чисел. Сколько среди них чётных?

2. Вводится последовательность чисел, заканчивающийся 0. Определить сколько чисел в этой последовательности.

+2
Ответы (1)
  1. 3 декабря, 17:05
    0
    Var n, i, a, k: integer;

    begin

    write ('Введите количество чисел (N) : ') ;

    readln (n) ;

    for i : = 1 to n do

    begin

    write ('Введите число: ') ;

    readln (a) ;

    if a mod 2 = 0 then k:=k+1;

    end;

    writeln ('Количество чётных чисел: ', k)

    end.

    var a, k:integer;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    while a0 do

    begin

    k:=k+1;

    write ('Введите число: ') ;

    readln (a)

    end;

    writeln ('Количество чисел в последовательности: ', k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. С клавиатуры вводитсядет N чисел. Сколько среди них чётных? 2. Вводится последовательность чисел, заканчивающийся 0. Определить сколько ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Я никогда не подружусь с этой темой ... 1. С клавиатуры вводится 7 целых чисел. Найти сумму всех нечетных среди них. 2. С клавиатуры вводится 7 целых чисел. Найти произведение чисел кратных 7. (Информатика. Тема: Pascal ABC. 8 класс)
Ответы (1)