Задать вопрос
26 января, 10:40

Вывести все натуральные трехзначные числа, в которых есть заданная цифра. На паскале.

+5
Ответы (1)
  1. 26 января, 12:35
    0
    Var A, I, O: Integer;

    Begin

    ReadLn (A) ;

    For I:=100 to 999 do Begin

    If I div 100 = A Then

    O:=O+1;

    if (I div 10) - (I div 100) = A then

    O:=O+1;

    If I - ((I div 10) * 10) = A Then

    O:=O+1;

    End;

    WriteLn (O) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вывести все натуральные трехзначные числа, в которых есть заданная цифра. На паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Написать программу в Паскале: 1) Вводятся 10 целых чисел. Подсчитать количество четных среди них 2) Вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры).
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Решить в Паскале с помощью операторов while и repeat 1) Вывести на экран все четные числа из диапазона от A до В, кратные трём (А
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)