Задать вопрос
11 августа, 12:23

Напишите программу вычисления площади и гипотенузы прямоугольного треугольника, если известны его катеты. Но программа должна быть с комментариями посторочно

+5
Ответы (1)
  1. 11 августа, 15:34
    0
    Var {раздел описания переменных}

    a, b: Real; {описание переменных. Переменные а и b вещественного типа}

    begin {раздел или блок непосредственно кода программы}

    WriteLn ('введите катеты') ; {запрос ввода сторон треугольника}

    ReadLn (a, b) ; {ввод сторон треугольника пользователем}

    Writeln ('Площадь треугольника = ', a*b/2) ; {вывод результата нахождения площади треугольника. Площадь равна половине произведения катетов}

    WriteLn ('Гипотенуза=', sqrt (sqr (a) + sqr (b))) ; {вывод результата нахождения гипотенузы. Квадрат гипотенузы равен сумме квадратов катетов, соответственно гипотенуза равна корню квадратному из суммы квадратов катетов. sqr - возведение в квадрат, sqrt - корень из числа.}

    end. {Конец кода программы}
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу вычисления площади и гипотенузы прямоугольного треугольника, если известны его катеты. Но программа должна быть с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Даны катеты прямоугольного треугольника. Составьте программу для нахождения гипотенузы, периметра и площади этого прямоугольного треугольника.
Ответы (1)
Дано три числа. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a < = b < = c, затем программа выводит тройку a, b, c.
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1. Cоставить программу вычисления площади круга: S = п (пи) * R^2 2. Cоставить программу вычисления площади треугольника: S=1/2*A*H 1) Выделить целую часть результата.
Ответы (1)