Задать вопрос
15 апреля, 17:53

Паскаль. В первой строке программы задаётся кол-во чисел, не превышающих 300. Найти максимальное число, оканчивающееся на 3.

+2
Ответы (1)
  1. 15 апреля, 19:05
    0
    Var i, n, x:integer;

    begin

    write ('Введите число: ') ;

    readln (n) ;

    for i:=1 to n do

    if i mod 10 = 3 then x:=i;

    writeln (x)

    end.

    Пример:

    Введите число: 100

    93
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. В первой строке программы задаётся кол-во чисел, не превышающих 300. Найти максимальное число, оканчивающееся на 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите программу на Паскаль, которая в последовательности натуральных чисел определяет максимальное отрицательное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)