Задать вопрос
16 октября, 21:48

Сортировать вторую половину по убыванию массив паскаль

+2
Ответы (1)
  1. 17 октября, 01:17
    0
    Const n=10;

    var a:array[1 ... 10] of integer;

    i, j, z:integer;

    begin

    writeln ('Исходный массив: ') ;

    for i:=1 to n do begin

    a[i]:=random (100) ;

    write (a[i]:4) ;

    end;

    writeln;

    for i:=6 to 9 do

    for j:=i+1 to 10 do

    if a[i]
    begin

    z:=a[i];

    a[i]:=a[j];

    a[j]:=z;

    end;

    Write ('Результат: ') ;

    for i:=1 to 10 do

    Write (a[i]:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сортировать вторую половину по убыванию массив паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сортировка массивов по возрастанию и по убыванию. Массив задается от датчика случайных чисел random (). Сортировать один и тот же исходный массив и по убыванию и по возрастанию значений элементов.
Ответы (1)
Заполнить двухмерный массив состоящий из 5x5 элементов, случайными числами в диапазоне от 0 до 100. Сформировать одномерный массив, состоящий из минимальных элементов строк исходного и """сортировать его по убыванию.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Язык программирования: Паскаль. Написать программу. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать первую половину по возрастанию, а вторую - по убыванию.
Ответы (1)