Задать вопрос
26 января, 07:50

Дана последовательность прлизвольных символов, подсчитать количество цифр в этой последовательности.

+2
Ответы (1)
  1. 26 января, 09:49
    0
    Var

    S: string;

    CountNumbers, i: byte;

    begin

    write ('Введите строку: ') ; readln (S) ;

    for i : = 1 to Length (S) do

    if S[i] in ['0' ... '9'] then CountNumbers : = CountNumbers + 1;

    writeln ('Количество цифр в строке = ', CountNumbers) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность прлизвольных символов, подсчитать количество цифр в этой последовательности. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Дана последовательность, состоящая из двух цифр? 12. К этой последовательности Незнайка решил применить такой алгоритм: 1) в конце данной последовательности дописать ее зеркальную копию;
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран: а) количество считанных десятичных цифр; б) количество четных цифр; в) количество нечетных цифр;
Ответы (1)