Задать вопрос
16 июля, 10:26

Написать программу "Калькулятор", которая выводит результат выполнения одной из операций (+; -; *; /) над двумя числами a и b. (Pascal)

+3
Ответы (1)
  1. 16 июля, 11:27
    0
    Var A, B:real;

    C:integer;

    Begin

    WriteLn (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход) ;

    ReadLn (C) ;

    While C 0 do

    Begin

    Write (Введите два числа:) ;

    ReadLn (A, B) ;

    Write (Ответ:) ;

    Case C of

    1:WriteLn (A+B) ;

    2:WriteLn (A-B) ;

    3:WriteLn (A*B) ;

    4:WriteLn (A/B) ;

    End;

    WriteLn (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход) ;

    ReadLn (C) ;

    End;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу "Калькулятор", которая выводит результат выполнения одной из операций (+; -; *; /) над двумя числами a и b. (Pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)