Задать вопрос
2 мая, 10:22

Напишите на Паскале программу. Вводятся 2 целых числа. Если одно из них является квадратом другого, то вывести 1, иначе вывести 0.

+3
Ответы (1)
  1. 2 мая, 11:40
    0
    Var

    a, b: integer;

    begin

    writeln ('Введите два числа') ;

    readln (a) ;

    readln (b) ;

    if (a*a=b) or (b*b=a) then

    writeln ('Вывод 1') else writeln ('Вывод 0') ;

    readln;

    end.

    {Тест}

    Введите два числа

    25

    5

    Вывод 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите на Паскале программу. Вводятся 2 целых числа. Если одно из них является квадратом другого, то вывести 1, иначе вывести 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то вывести - 1 например 4 является квадратом 2 а 17 не является квадратом никакого числа.
Ответы (1)
Вводятся два натуральных числа. если оба числа чётные, то вывести большее из них. если оба числа не чётные, то вывести меньшее из них. если одно чётное, а другое не чётное, то вывести их произведение на экран.
Ответы (2)
Написать программу в Паскале: 1) Вводятся 10 целых чисел. Подсчитать количество четных среди них 2) Вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры).
Ответы (1)
С клавиатуры вводятся 2 числа. Если хотя бы одно из этих чисел является трёхзначным и кратным 3, вывести слово YES, иначе возвести первое число в квадрат, а из второго извлеч корень, вывести эти числа на экран
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)